Repository navigation
fix(deps): patch body-parser to 2.4.0 - #1447
cipherstash-agent wants to merge 1 commit into
Conversation
Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_012Jmn7ng9L3hDYRnUZpQPbN
|
cipherstash-agent
left a comment
There was a problem hiding this comment.
Review attestation at ccdbd9a: /code-review medium plus company-skills:cross-check-review-findings, run by Claude Code.
Critical/blocking issues: none.
- Lockfile and override change are consistent:
body-parser2.3.0 → 2.4.0 (fixes GHSA-27r3-jxmh-p828, range>=2.0.0 <2.4.0), withqs6.16.1 pulled in as the new dependency. - 1 minor finding posted inline (the override does not reach npm consumers of
@cipherstash/wizard). - Checked and dropped: the
qsduplicate is disclosed in the PR body, and the 7-day install cooldown is satisfied (2.4.0 published 2026-10-22) and does not affect--frozen-lockfileinstalls. - No existing human or bot review findings to cross-check against.
Generated by Claude Code
| 'sharp@<0.35.5': '0.35.5' | ||
| # #279 CVE-2026-111181 (GHSA-27r3-jxmh-p828, HIGH) — body-parser 2.x; fixed in | ||
| # 2.4.0. Reached through express 5 (`^2.2.1`) via @modelcontextprotocol/sdk. | ||
| 'body-parser@>=2.0.0 <2.4.0': '2.4.0' |
There was a problem hiding this comment.
minor This override applies only to this repo's lockfile; pnpm overrides are not published, so @cipherstash/wizard installs from npm still resolve body-parser through express and @modelcontextprotocol/sdk ranges and can land below 2.4.0. If consumers should be protected, add a direct body-parser floor to the wizard's dependencies; otherwise state in the PR that the remediation covers repo installs only.
Generated by Claude Code
Summary
Patches
body-parserto 2.4.0 in the rootpnpm-lock.yaml, the only lockfile that resolved a vulnerable version.Advisories
>= 2.0.0, < 2.4.0, fixed in 2.4.0. Dependabot alert: https://github.com/cipherstash/stack/security/dependabot/279Versions
pnpm-lock.yamlChanges
body-parseris transitive (express@5.2.1→@modelcontextprotocol/sdk→@anthropic-ai/claude-agent-sdk→@cipherstash/wizard).An in-range
pnpm update -r body-parseralso movedrollup4.64.12 → 4.65.0 and the platform packages with it, so I used the repo's existing convention instead: a security override inpnpm-workspace.yaml, scoped to the vulnerable range ('body-parser@>=2.0.0 <2.4.0': '2.4.0').The override can be removed once
expressor the SDKs above resolve body-parser 2.4.0 on their own.One extra package moved:
qs6.16.0 → 6.16.1, becausebody-parser@2.4.0requires it. This is the same version PR #1434 targets.No changeset: this only changes the lockfile and workspace overrides, not a published package's surface.
Verification
pnpm install --lockfile-only --ignore-scriptswith the override, then--frozen-lockfilecheck, both clean.deps.pyover the branch: exit 0, no lockfile resolves a vulnerable version.pnpm-lock.yamlandpnpm-workspace.yamlchanged.Generated by Claude Code
Summary by CodeRabbit