Repository navigation
CLDSRV-1052: Bump Node.js to 24.22.1 and refresh yarn.lock - #6343
francoisferrand wants to merge 2 commits into
Conversation
Node 24.22.1 updates the bundled root store to NSS 3.131.1, which blocks the compromised eMudhra/emSign intermediate CAs. Issue: CLDSRV-1052
Pick up the latest dependency versions allowed by package.json, which fixes most of the yarn audit findings. Issue: CLDSRV-1052
Hello francoisferrand,My role is to assist you with the merge of this Available options
Available commands
Status report is not available. |
Incorrect fix versionThe
Considering where you are trying to merge, I ignored possible hotfix versions and I expected to find:
Please check the |
Codecov Report✅ All modified and coverable lines are covered by tests. Additional details and impacted files
@@ Coverage Diff @@
## development/9.5 #6343 +/- ##
===================================================
- Coverage 90.23% 90.20% -0.03%
===================================================
Files 206 206
Lines 38673 38673
===================================================
- Hits 34897 34886 -11
- Misses 3776 3787 +11
Flags with carried forward coverage won't be shown. Click here to find out more. 🚀 New features to boost your workflow:
|
Request integration branchesWaiting for integration branch creation to be requested by the user. To request integration branches, please comment on this pull request with the following command: Alternatively, the |
| version "8.6.0" | ||
| resolved "https://registry.yarnpkg.com/@scality/arsenal/-/arsenal-8.6.0.tgz#7d8422893a6f498894e04509cb07f1bcb224e5ab" | ||
| integrity sha512-RxYMTZf23vd4P1lQEm/H7Jy0yIFZ+2/uFqpp7tLD4lj8iu6Lj8MsF+KxWfB3QLvwVKx9QPsMqSe06QaOPwqh4Q== | ||
| "@scality/arsenal@^8.6.0": |
There was a problem hiding this comment.
The "@scality/arsenal@^8.6.0-0" pattern was dropped, but @scality/utapi still requires "@scality/arsenal" "^8.6.0-0" (line 1409). Without a lock entry for that range, yarn resolves it from the registry at install time. If a newer arsenal 8.x is published, utapi can get a different copy than the one locked here. Running yarn install would add the pattern back, so keep it on this entry:
| "@scality/arsenal@^8.6.0": | |
| "@scality/arsenal@^8.6.0", "@scality/arsenal@^8.6.0-0": |
Node 24.22.1 updates the bundled root store to NSS 3.131.1, which blocks the compromised eMudhra/emSign intermediate CAs. The Dockerfile was the only place pinning the patch version; CI already uses
24.Also refreshed
yarn.lockto pick up the latest versions allowed bypackage.json, bringingyarn auditfrom 17 findings down to 3. No new duplicate versions:encodingandjs-yaml@^5were kept at their previous versions, since the newer ones only added duplicates (iconv-lite@0.7,argparse@3) without any security benefit. The remaining high findings are in@azure/msal-node, which comes in through arsenal.Issue: CLDSRV-1052