Repository navigation
fix(deps): patch qs to 6.16.1 - #1434
cipherstash-agent wants to merge 1 commit into
Conversation
Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_012Jmn7r7LjBn2Pj9k3RHUWF
|
|
Important Review skippedReview was skipped due to path filters ⛔ Files ignored due to path filters: 1
CodeRabbit blocks several paths by default. You can override this behavior by explicitly including those paths in the path filters. For example, including
|
cipherstash-agent
left a comment
There was a problem hiding this comment.
Review attestation — source: /code-review medium followed by company-skills:cross-check-review-findings, run against head 1f546ba.
Result: no critical or blocking issues. No new findings.
- The diff is
pnpm-lock.yamlonly:qs6.16.0 → 6.16.1, which is the fixed version for GHSA-6pq8-jhm2-2vcw. - The package entry,
body-parserandexpressreferences were updated together, and the integrity hash matches the registry value forqs@6.16.1. - 6.16.1 was published 2026-10-14, so it is past the 7-day
minimumReleaseAge. - Three observations were dropped as non-defects or already covered:
- no
overridesentry pinsqs(the PR deliberately skips one); qs6.16.2 is newer but still inside the release-age window;- the missing changeset is already flagged by
changeset-bot.
- no
Nothing to fix before merge.
Generated by Claude Code
freshtonic
left a comment
There was a problem hiding this comment.
Approve. The change is to pnpm-lock.yaml only: qs 6.16.0 → 6.16.1 (reached through body-parser / express).
Verified:
- GHSA-6pq8-jhm2-2vcw (CVE-2026-110816) affects
>= 6.7.0, <= 6.16.0, and 6.16.1 is the first fixed version. - The lockfile integrity hash is the same as the one npm publishes for
qs@6.16.1. - 6.16.1 was published on 2026-10-14, so it is past the 7-day
minimumReleaseAge. A later re-resolve cannot fall back to 6.16.0. pnpm-lock.yamlis the only tracked lockfile that resolvesqs, and it resolves no other version.- No changeset is necessary, because no published manifest changes.
Nit (not blocking): no override stops a later re-resolve from going back to a vulnerable qs. This is acceptable because the patched version is past the cooldown.
Summary
Patches the transitive
qsdependency to 6.16.1.Advisories
>= 6.7.0, <= 6.16.0, fixed in 6.16.1 (Dependabot alert Searchable json integration tests #284).Changes
pnpm-lock.yamlqs6.16.0qs6.16.1qsis reached throughbody-parser→express→@modelcontextprotocol/sdk→@anthropic-ai/claude-agent-sdk→@cipherstash/wizard. The change came frompnpm update -r qs, so it needed no override and touches only the lockfile.Verification
pnpm install --frozen-lockfile --ignore-scriptspasses on the branch.qs(only 6.16.1 is resolved).pnpm-lock.yamlonly.CI runs the test suites.
Generated by Claude Code